MustangWorks.com - The Ford Mustang Power Source!

Go Back   MustangWorks.com : Ford Forums > Website Community > Stang Stories
Register FAQ Members List Calendar Mark Forums Read

Notices


Reply
 
LinkBack Thread Tools Rate Thread Display Modes
Old 05-30-2005, 11:24 PM   #1 (permalink)
91rcktstang
Registered Member
 
Join Date: May 2005
Location: SLC Utah
Posts: 9
Default Running Hot

My 1991 LX is running hot, it ever so slowly climbs to 210 somestimes as high as 220. Its has a new radiator, flushed out the entire system twice to be safe, and installed a 180 degree Thermostat. I even checked the timing. Im running BBK storty headers, BBK H pipe, JMAC Catback, chipped with 3.73 gears and AOD with 2400 RPM stall converter..... Any advice out there, its an Auto Meter temp gauge could it be bad.

Last edited by 91rcktstang; 06-02-2005 at 01:07 AM..
91rcktstang is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
Old 06-28-2005, 06:55 PM   #2 (permalink)
foncarelli
Registered Member
 
foncarelli's Avatar
 
Join Date: Jun 2005
Posts: 2
Default Re: Running Hot

Make sure the overflow doesnt have a hole in it and do you have a new radiator cap?
__________________
2000 GT P1SC, 3 core intercooler,Livernois Motorsport custom cams, 42lb Lucas inj., 90mmSCT meter, SVT Focus pump, 3:37 gears, 2800 stall(PI), TransGo Shift kit, B&M Trans cooler, etc.
foncarelli is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
Old 06-29-2005, 03:02 PM   #3 (permalink)
Jayme
12 Sec Stock Motor Club
 
Join Date: Jun 2002
Location: Baytown, TX
Posts: 15
Default Re: Running Hot

Quote:
Originally Posted by 91rcktstang
My 1991 LX is running hot, it ever so slowly climbs to 210 somestimes as high as 220. Its has a new radiator, flushed out the entire system twice to be safe, and installed a 180 degree Thermostat. I even checked the timing. Im running BBK storty headers, BBK H pipe, JMAC Catback, chipped with 3.73 gears and AOD with 2400 RPM stall converter..... Any advice out there, its an Auto Meter temp gauge could it be bad.
take a look at the water pump?
__________________
-Jayme

1990 Mustang LX
12.16 @ 116.65mph
My NEW MustangWorks Page

1990 Mustang GT -Sold-
12.996 @ 104.21mph
1.72 RRs, Pro-M 75mm MAF, Kirban Regulator, BBK Headers, BBK Off-Road X-Pipe, MAC Cat-Back, ASP Pulleys, BBK 70mm TB/EGR, BBK Cold Air, 3.73 Gears, Hurst Short Throw, King Cobra Clutch, 4-Cyl Front Springs, BBK Rear, 90/10 Struts & 50/50 Shocks, Lakewood Lower Control Arms and Weld Draglites.
My MustangWorks Page
Jayme is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
Old 06-29-2005, 03:11 PM   #4 (permalink)
SVT4ME
Powered by SVT
 
SVT4ME's Avatar
 
Join Date: Jun 2005
Location: NC
Posts: 4
Default Re: Running Hot

Quote:
Originally Posted by Jayme
take a look at the water pump?
Look to see if there is any water around the weep hole on it. That is probably the culprit. Easy to replace too!

I was having heating issues on my coupe, so I replaced the fan with a Black Magic, the water pump, new aluminum rad and dropped in a 180 thermostat. Not sure exactly what the problem was, but I fixed it.
__________________
1994 Cobra
2000 Lightning
www.horsepowerjunkies.com
www.fastlanemotorsports.us
SVT4ME is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
Old 07-05-2005, 12:49 AM   #5 (permalink)
91rcktstang
Registered Member
 
Join Date: May 2005
Location: SLC Utah
Posts: 9
Default Re: Running Hot

it was the radiator, replaced with a 3 core runs right at 190 degrees now, thanks
91rcktstang is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
Sponsored Links
Reply


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



Similar Threads
Thread Thread Starter Forum Replies Last Post
Car running lean, any suggestions? MATTKNIGHT Windsor Power 10 03-08-2009 03:52 PM
What headunit are you running? tireburner163 Audio, Security, & Electronics 0 04-22-2003 01:33 AM
Fuel pump will not stop running MustangGT1990 Windsor Power 7 01-29-2003 09:41 PM
running rich? reignman Windsor Power 2 11-13-2002 09:19 PM
Car's running hot... Sonics2042 Windsor Power 8 07-16-2002 04:50 PM


All times are GMT -5. The time now is 12:38 PM.


SEARCH