MustangWorks.com - The Ford Mustang Power Source!

Go Back   MustangWorks.com : Ford Forums > Mustang & Ford Tech > Modular Madness
Register FAQ Members List Calendar Mark Forums Read

Notices


Reply
 
LinkBack Thread Tools Rate Thread Display Modes
Old 02-26-2009, 05:23 PM   #1 (permalink)
tommunz@comcast.net
Registered Member
 
Join Date: Feb 2009
Location: Lehigh Acres, Florida
Posts: 1
Default 98 GT Problem

I had the freeze plugs and clutch replaced on my pony. When I got it back from the mechanic, it ran horrible. He replaced the spark plugs but it still runs bad. Does anyone have any idea what the mechanic might have screwed up to cause this? It has 70,000 miles and ran wonderful beforehand with no after market products on the engine.

Vacuum hose? Fuel filter? Please help!!
tommunz@comcast.net is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
Old 09-09-2010, 03:04 PM   #2 (permalink)
don blaze
96 PI
 
Join Date: Sep 2010
Location: Mercedes tx
Posts: 2
Default Re: 98 GT Problem

When u slam on tha gas how does ur car respond
don blaze is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
Old 12-16-2010, 12:38 AM   #3 (permalink)
mjacoby321
Banned
 
Join Date: Sep 2010
Posts: 15
Default Re: 98 GT Problem

i think its the spark plugs dude. it really depends on the Car Repair procedure if it has been arranged properly.
mjacoby321 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
Old 08-20-2012, 09:41 AM   #4 (permalink)
WorkHorse
Registered Member
 
Join Date: Aug 2012
Posts: 3
Default Re: 98 GT Problem

Man that is too bad, you want to be able to trust the people that work on your car. Especially if you didn't even do any after market work on it. Best to look around alot for solid car mechanics and go from there.
WorkHorse is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
Sponsored Links
Reply


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



Similar Threads
Thread Thread Starter Forum Replies Last Post
FPR Problem Z28EATR Windsor Power 6 04-05-2004 11:05 AM
Problem with 302.. Smokedawg Windsor Power 6 01-30-2003 03:22 PM
Do I have a big problem?? RPM427 Windsor Power 4 11-10-2002 02:00 PM
Is this an EGR problem? mustangLX92 Windsor Power 1 06-27-2001 01:04 AM
T5 problem sadlsor7 Windsor Power 3 05-01-2001 01:50 PM


All times are GMT -5. The time now is 01:38 AM.


SEARCH